php 3.0.7

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // General
View previous topic :: View next topic  
Author Message
love_bug



Joined: 26 Nov 2009
Posts: 3

PostPosted: Sun Sep 05, 2010 11:48 pm    Post subject: php 3.0.7 Reply with quote
hi, I've recently upgraded my phpbb 3.0.6 to 3.0.7,
it was working fine, and now suddenly i am not able to log in, i get following error :

Quote:
You are not a member of the required group!


As far as i know I have all the settings right, is it because they changed group table structure etc?
here my settings.
Code:

require_once './extensions/Auth_phpBB.php';
$wgAuth_Config = array(); // Clean.

//$wgAuth_Config['WikiGroupName'] = array('Registered users','Global moderators','Administrators');       // Name of your PHPBB group

$wgAuth_Config['WikiGroupName'][] = 'Registered users';
$wgAuth_Config['WikiGroupName'][] = 'Global moderators';
$wgAuth_Config['WikiGroupName'][] = 'Administrators';
                                                // users need to be a member
                                                // of to use the wiki. (i.e. wiki)
                  // This can also be set to an array
                  // of group names to use more then
                  // one. (ie.
                  // $wgAuth_Config['WikiGroupName'][] = 'Wiki';
                  // $wgAuth_Config['WikiGroupName'][] = 'Wiki2';
                  // or
                  // $wgAuth_Config['WikiGroupName'] = array('Wiki', 'Wiki2');
                  // )


$wgAuth_Config['UseWikiGroup'] = true;          // This tells the Plugin to require
                                                // a user to be a member of the above
                                                // phpBB group. (ie. wiki) Setting
                                                // this to false will let any phpBB
                                                // user edit the wiki.

$wgAuth_Config['UseExtDatabase'] = false;       // This tells the plugin that the phpBB tables
                                                // are in a different database then the wiki.
                                                // The default settings is false.

//$wgAuth_Config['MySQL_Host']        = 'localhost';      // phpBB MySQL Host Name.
//$wgAuth_Config['MySQL_Username']    = 'username';       // phpBB MySQL Username.
//$wgAuth_Config['MySQL_Password']    = 'password';       // phpBB MySQL Password.
//$wgAuth_Config['MySQL_Database']    = 'database';       // phpBB MySQL Database Name.

$wgAuth_Config['UserTB']         = 'phpbb_users';       // Name of your PHPBB user table. (i.e. phpbb_users)
$wgAuth_Config['GroupsTB']       = 'phpbb_groups';      // Name of your PHPBB groups table. (i.e. phpbb_groups)
$wgAuth_Config['User_GroupTB']   = 'phpbb_user_group';  // Name of your PHPBB user_group table. (i.e. phpbb_user_group)
$wgAuth_Config['PathToPHPBB']    = '../';         // Path from this file to your phpBB install.

// Local
$wgAuth_Config['LoginMessage']   = '<b>You need a Sikkimonline phpBB forums account to login.</b><br /><a href="' . $wgAuth_Config['PathToPHPBB'] .
                                   'ucp.php?mode=register">Click here to create an account.</a>'; // Localize this message.
$wgAuth_Config['NoWikiError']    = 'You are not a member of the required group!'; // Localize this message.

$wgAuth = new Auth_phpBB($wgAuth_Config);     // Auth_phpBB Plugin.


thank you.
Back to top
View user's profile Send private message
love_bug



Joined: 26 Nov 2009
Posts: 3

PostPosted: Mon Sep 06, 2010 12:11 am    Post subject: Reply with quote
nevermind it's solved Smile

Yea phpbb they have changed group name i guess lol.

"Registered User" was "REGISTERED" in database table and all other group names were in cap.
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Tue Sep 07, 2010 10:09 am    Post subject: Reply with quote
ok
Back to top
View user's profile Send private message
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // General All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

alexisBlue v1.2 // Theme Created By: Andrew Charron and Web Hosting Bluebook
Powered by phpBB © 2001, 2002 phpBB Group