I Don't Even Know

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // General
View previous topic :: View next topic  
Author Message
Jynx



Joined: 26 Jan 2011
Posts: 8
Location: Everywhere

PostPosted: Wed Jan 26, 2011 4:42 pm    Post subject: I Don't Even Know Reply with quote
When i navigate to the wiki i get this:

Code:

Notice: Undefined index: asersmia_phpb1 in /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php on line 243

Notice: Undefined index: localhost in /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php on line 244

Notice: Undefined index: XXXXXXXXXXXX in /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php on line 245

Notice: Undefined index: asersmia_phpb1 in /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php on line 246

Warning: Cannot modify header information - headers already sent by (output started at /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php:243) in /home/asersmia/public_html/twenty-thirteen-wiki/includes/WebResponse.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php:243) in /home/asersmia/public_html/twenty-thirteen-wiki/includes/WebResponse.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php:243) in /home/asersmia/public_html/twenty-thirteen-wiki/includes/WebResponse.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php:243) in /home/asersmia/public_html/twenty-thirteen-wiki/includes/WebResponse.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php:243) in /home/asersmia/public_html/twenty-thirteen-wiki/includes/WebResponse.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php:243) in /home/asersmia/public_html/twenty-thirteen-wiki/includes/WebResponse.php on line 16

Warning: Cannot modify header information - headers already sent by (output started at /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php:243) in /home/asersmia/public_html/twenty-thirteen-wiki/includes/WebResponse.php on line 16


^Password Has been blacked out
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Thu Jan 27, 2011 10:24 am    Post subject: Reply with quote
My guess is that you did not put your setting into quotes. Would you post what your Auth_phpBB settings in LocalSettings.php look like? (black out the username and password.)
Back to top
View user's profile Send private message
Jynx



Joined: 26 Jan 2011
Posts: 8
Location: Everywhere

PostPosted: Thu Jan 27, 2011 5:19 pm    Post subject: Reply with quote
This is what i added to my localsettings.php

Code:
// PHPBB User Database Plugin. (Requires MySQL Database)
require_once './extensions/Auth_phpBB.php';

$wgAuth_Config = array(); // Clean.

$wgAuth_Config['WikiGroupName'] = 'Wiki';       // Name of your PHPBB group
                                                // users need to be a member
                                                // of to use the wiki. (i.e. wiki)
                  // This can also be set to an array
                  // of group names to use more then
                  // one. (ie.
                  // $wgAuth_Config['WikiGroupName'][] = 'Wiki';
                  // $wgAuth_Config['WikiGroupName'][] = 'Wiki2';
                  // or
                  // $wgAuth_Config['WikiGroupName'] = array('Wiki', 'Wiki2');
                  // )


$wgAuth_Config['UseWikiGroup'] = true;          // This tells the Plugin to require
                                                // a user to be a member of the above
                                                // phpBB group. (ie. wiki) Setting
                                                // this to false will let any phpBB
                                                // user edit the wiki.

$wgAuth_Config['UseExtDatabase'] = true;       // This tells the plugin that the phpBB tables
                                                // are in a different database then the wiki.
                                                // The default settings is false.

//$wgAuth_Config['MySQL_Host']        = 'localhost';      // phpBB MySQL Host Name.
//$wgAuth_Config['MySQL_Username']    = 'XXUSERNAMEXX';       // phpBB MySQL Username.
//$wgAuth_Config['MySQL_Password']    = 'XXPASSWORDZZ';       // phpBB MySQL Password.
//$wgAuth_Config['MySQL_Database']    = 'asersmia_phpb1';       // phpBB MySQL Database Name.

$wgAuth_Config['UserTB']         = 'phpbb_users';       // Name of your PHPBB user table. (i.e. phpbb_users)
$wgAuth_Config['GroupsTB']       = 'phpbb_groups';      // Name of your PHPBB groups table. (i.e. phpbb_groups)
$wgAuth_Config['User_GroupTB']   = 'phpbb_user_group';  // Name of your PHPBB user_group table. (i.e. phpbb_user_group)
$wgAuth_Config['PathToPHPBB']    = '../twenty-thirteen/';         // Path from this file to your phpBB install.

// Local
$wgAuth_Config['LoginMessage']   = '<b>You need a Twenty-Thirteen account to login.</b><br /><a href="' . $wgAuth_Config['PathToPHPBB'] .
                                   'ucp.php?mode=register">Click here to create an account.</a>'; // Localize this message.
$wgAuth_Config['NoWikiError']    = 'You are not a member of the required group.'; // Localize this message.

$wgAuth = new Auth_phpBB($wgAuth_Config);     // Auth_phpBB Plugin.
Back to top
View user's profile Send private message
Jynx



Joined: 26 Jan 2011
Posts: 8
Location: Everywhere

PostPosted: Thu Jan 27, 2011 5:23 pm    Post subject: Reply with quote
this is from the auth_phpbb extension

Code:
// Only assign the database values if a external database is used.
            if ($this->_UseExtDatabase == true)
            {
                $this->_MySQL_Database  = $aConfig['asersmia_phpb1'];
                $this->_MySQL_Host      = $aConfig['localhost'];
                $this->_MySQL_Password  = $aConfig['XXPASSWORDZZ'];
                $this->_MySQL_Username  = $aConfig['XXUSERNAMEXX'];
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Fri Jan 28, 2011 11:10 am    Post subject: Reply with quote
Well that might explain your problem. Do Not Edit Auth_phpBB.php download a fresh copy and try again.
Back to top
View user's profile Send private message
Jynx



Joined: 26 Jan 2011
Posts: 8
Location: Everywhere

PostPosted: Sun Jan 30, 2011 6:22 am    Post subject: Reply with quote
all that did was change the first part of the errors to

Code:
Notice: Undefined index: MySQL_Database in /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php on line 243

Notice: Undefined index: MySQL_Host in /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php on line 244

Notice: Undefined index: MySQL_Password in /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php on line 245

Notice: Undefined index: MySQL_Username in /home/asersmia/public_html/twenty-thirteen-wiki/extensions/Auth_phpBB.php on line 246
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Mon Jan 31, 2011 2:07 pm    Post subject: Reply with quote
in your LocalSettings.php file you have this.

Code:
//$wgAuth_Config['MySQL_Host']        = 'localhost';      // phpBB MySQL Host Name.
//$wgAuth_Config['MySQL_Username']    = 'XXUSERNAMEXX';       // phpBB MySQL Username.
//$wgAuth_Config['MySQL_Password']    = 'XXPASSWORDZZ';       // phpBB MySQL Password.
//$wgAuth_Config['MySQL_Database']    = 'asersmia_phpb1';       // phpBB MySQL Database Name.


change it to this.

Code:
$wgAuth_Config['MySQL_Host']        = 'localhost';      // phpBB MySQL Host Name.
$wgAuth_Config['MySQL_Username']    = 'XXUSERNAMEXX';       // phpBB MySQL Username.
$wgAuth_Config['MySQL_Password']    = 'XXPASSWORDZZ';       // phpBB MySQL Password.
$wgAuth_Config['MySQL_Database']    = 'asersmia_phpb1';       // phpBB MySQL Database Name.
Back to top
View user's profile Send private message
Jynx



Joined: 26 Jan 2011
Posts: 8
Location: Everywhere

PostPosted: Mon Jan 31, 2011 5:39 pm    Post subject: Reply with quote
that fixed it.
new problem

Ive gotten it to where my Phpbb acct is a member of the Bureaucrat and sysop usergroups. Yet it still cannot access restricted pages, like editing (which is sysop only) yes he can create (which is also sysop only)
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Tue Feb 01, 2011 7:16 am    Post subject: Reply with quote
Sounds like a permission issue.

Try removing the plug-in and get your mw acct to work as you want it to. Then add the plug-in back.
Back to top
View user's profile Send private message
Jynx



Joined: 26 Jan 2011
Posts: 8
Location: Everywhere

PostPosted: Tue Feb 01, 2011 12:55 pm    Post subject: Reply with quote
the MW acct works fine. Its an acct from the phpBB DB that im wanting to give perms to
Back to top
View user's profile Send private message
Jynx



Joined: 26 Jan 2011
Posts: 8
Location: Everywhere

PostPosted: Wed Feb 02, 2011 5:11 pm    Post subject: Reply with quote
Correction!

With this mod installed, none of the accounts can edit posts. if i switch back to the old DB, the original sysop acct (admin) can edit anything. But with the new configuration my new sysop (J) who is also a bureaucrat cannot edit anything. He can't even edit a page if he creates it.

Help?
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Thu Feb 03, 2011 1:09 pm    Post subject: Reply with quote
Jynx wrote:
Correction!

With this mod installed, none of the accounts can edit posts. if i switch back to the old DB, the original sysop acct (admin) can edit anything. But with the new configuration my new sysop (J) who is also a bureaucrat cannot edit anything. He can't even edit a page if he creates it.

Help?


    Remove the plug-in.
    Get your "new sysop (J) who is also a bureaucrat" account working as you want it to.
    Add the plug-in.
Back to top
View user's profile Send private message
Jynx



Joined: 26 Jan 2011
Posts: 8
Location: Everywhere

PostPosted: Wed Feb 09, 2011 11:25 am    Post subject: Reply with quote
Problem persists.
Back to top
View user's profile Send private message
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // General All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

alexisBlue v1.2 // Theme Created By: Andrew Charron and Web Hosting Bluebook
Powered by phpBB © 2001, 2002 phpBB Group