MYSQL Error

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // How do I?
View previous topic :: View next topic  
Author Message
Reina



Joined: 17 May 2013
Posts: 1

PostPosted: Fri May 17, 2013 7:16 am    Post subject: MYSQL Error Reply with quote
I am having a hard way to go installing this integration between phpbb3 and mediawiki. I'm at my wits end. My site is throwing this error:

Quote:
Notice: Undefined index: MySQL_Host in /home/wod20/wodrpg20.com/wiki/extensions/Auth_phpbb.php on line 244

Notice: Undefined index: MySQL_Password in /home/wod20/wodrpg20.com/wiki/extensions/Auth_phpbb.php on line 245

Notice: Undefined index: MySQL_Username in /home/wod20/wodrpg20.com/wiki/extensions/Auth_phpbb.php on line 246

Warning: Cannot modify header information - headers already sent by (output started at /home/wod20/wodrpg20.com/wiki/extensions/Auth_phpbb.php:243) in /home/wod20/wodrpg20.com/wiki/includes/WebResponse.php on line 38

Warning: Cannot modify header information - headers already sent by (output started at /home/wod20/wodrpg20.com/wiki/extensions/Auth_phpbb.php:243) in /home/wod20/wodrpg20.com/wiki/includes/WebResponse.php on line 38
Unexpected non-MediaWiki exception encountered, of type "Exception"
exception 'Exception' with message 'There was a problem when connecting to the phpBB database.<br />Check your Host, Username, and Password settings.<br /><br />MySQL Error Number: 0<br />MySQL Error Message: <br /><br />' in /home/wod20/wodrpg20.com/wiki/extensions/Auth_phpbb.php:699
Stack trace:
#0 /home/wod20/wodrpg20.com/wiki/extensions/Auth_phpbb.php(428): Auth_phpbb->mySQLError('There was a pro...')
#1 /home/wod20/wodrpg20.com/wiki/extensions/Auth_phpbb.php(491): Auth_phpbb->connect()
#2 /home/wod20/wodrpg20.com/wiki/includes/User.php(770): Auth_phpbb->getCanonicalName('Rae')
#3 /home/wod20/wodrpg20.com/wiki/includes/User.php(359): User::getCanonicalName('Rae', 'valid')
#4 /home/wod20/wodrpg20.com/wiki/includes/resourceloader/ResourceLoaderUserGroupsModule.php(35): User::newFromName('Rae')
#5 /home/wod20/wodrpg20.com/wiki/includes/resourceloader/ResourceLoaderWikiModule.php(192): ResourceLoaderUserGroupsModule->getPages(Object(ResourceLoaderContext))
#6 /home/wod20/wodrpg20.com/wiki/includes/resourceloader/ResourceLoaderWikiModule.php(169): ResourceLoaderWikiModule->getTitleMtimes(Object(ResourceLoaderContext))
#7 /home/wod20/wodrpg20.com/wiki/includes/OutputPage.php(2578): ResourceLoaderWikiModule->isKnownEmpty(Object(ResourceLoaderContext))
#8 /home/wod20/wodrpg20.com/wiki/includes/OutputPage.php(2785): OutputPage->makeResourceLoaderLink(Array, 'combined', false, Array, false)
#9 /home/wod20/wodrpg20.com/wiki/includes/OutputPage.php(2796): OutputPage->getScriptsForBottomQueue(false)
#10 /home/wod20/wodrpg20.com/wiki/includes/Skin.php(635): OutputPage->getBottomScripts()
#11 /home/wod20/wodrpg20.com/wiki/includes/SkinTemplate.php(401): Skin->bottomScripts()
#12 /home/wod20/wodrpg20.com/wiki/includes/OutputPage.php(1982): SkinTemplate->outputPage()
#13 /home/wod20/wodrpg20.com/wiki/includes/Wiki.php(406): OutputPage->output()
#14 /home/wod20/wodrpg20.com/wiki/includes/Wiki.php(594): MediaWiki->finalCleanup()
#15 /home/wod20/wodrpg20.com/wiki/includes/Wiki.php(503): MediaWiki->main()
#16 /home/wod20/wodrpg20.com/wiki/index.php(5Cool: MediaWiki->run()
#17 {main}


However, the mysql information is correct. I copied it directly from the phpbb3 config file and I double checked in phpmyadmin. Any ideas how to fix this?

Thanks
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Fri May 17, 2013 1:29 pm    Post subject: Reply with quote
Did you add the settings to LocalSettings.php?

Check out the install part of this.

https://github.com/Digitalroot/MediaWiki_PHPBB_Auth
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Fri May 17, 2013 1:31 pm    Post subject: Reply with quote
FYI

Code:

    //$wgAuth_Config['MySQL_Host']        = 'localhost';      // phpBB MySQL Host Name.
    //$wgAuth_Config['MySQL_Username']    = 'username';       // phpBB MySQL Username.
    //$wgAuth_Config['MySQL_Password']    = 'password';       // phpBB MySQL Password.
    //$wgAuth_Config['MySQL_Database']    = 'database';       // phpBB MySQL Database Name.


These settings have the // in front of them so they are commented out. remove the //.

i.e.
Code:

    $wgAuth_Config['MySQL_Host']        = 'localhost';      // phpBB MySQL Host Name.
    $wgAuth_Config['MySQL_Username']    = 'username';       // phpBB MySQL Username.
    $wgAuth_Config['MySQL_Password']    = 'password';       // phpBB MySQL Password.
    $wgAuth_Config['MySQL_Database']    = 'database';       // phpBB MySQL Database Name.
Back to top
View user's profile Send private message
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // How do I? All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

alexisBlue v1.2 // Theme Created By: Andrew Charron and Web Hosting Bluebook
Powered by phpBB © 2001, 2002 phpBB Group