cannot log in....

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // How do I?
View previous topic :: View next topic  
Author Message
morths



Joined: 15 Dec 2008
Posts: 3

PostPosted: Mon Dec 15, 2008 7:25 pm    Post subject: cannot log in.... Reply with quote
Hi to all!!

The following errors come up every time i try to log in...

Code:
exception 'Exception' with message 'Unable to find phpBB installed at (/phpBB3/).' in C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\extensions\Auth_phpBB.php:650 Stack trace: #0 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\extensions\Auth_phpBB.php(917): Auth_phpBB->loadPHPFiles('UTF8') #1 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\extensions\Auth_phpBB.php(493): Auth_phpBB->utf8('Morths') #2 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\User.php(609): Auth_phpBB->getCanonicalName('Morths') #3 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\User.php(306): User::getCanonicalName('Morths', 'valid') #4 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\specials\SpecialUserlogin.php(385): User::newFromName('Morths') #5 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\specials\SpecialUserlogin.php(493): LoginForm->authenticateUserData() #6 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\specials\SpecialUserlogin.php(102): LoginForm->processLogin() #7 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\specials\SpecialUserlogin.php(17): LoginForm->execute() #8 [internal function]: wfSpecialUserlogin(NULL, Object(SpecialPage)) #9 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\SpecialPage.php(748): call_user_func('wfSpecialUserlo...', NULL, Object(SpecialPage)) #10 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\SpecialPage.php(534): SpecialPage->execute(NULL) #11 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\Wiki.php(224): SpecialPage::executePath(Object(Title)) #12 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\includes\Wiki.php(55): MediaWiki->initializeSpecialCases(Object(Title), Object(OutputPage), Object(WebRequest)) #13 C:\Inetpub\vhosts\onepiece.gr\httpdocs\mkportal\modules\mediawiki\index.php(93): MediaWiki->initialize(Object(Title), NULL, Object(OutputPage), Object(User), Object(WebRequest)) #14 {main}


Although when i click to register, it redirects me to my phpbb3 board...

Here is the LocalSettings.php i use when i get the above errors:

Code:
<?php

# This file was automatically generated by the MediaWiki installer.
# If you make manual changes, please keep track in case you need to
# recreate them later.
#
# See includes/DefaultSettings.php for all configurable settings
# and their default values, but don't forget to make changes in _this_
# file, not there.
#
# Further documentation for configuration settings may be found at:
# http://www.mediawiki.org/wiki/Manual:Configuration_settings

# If you customize your file layout, set $IP to the directory that contains
# the other MediaWiki files. It will be used as a base to locate files.
if( defined( 'MW_INSTALL_PATH' ) ) {
   $IP = MW_INSTALL_PATH;
} else {
   $IP = dirname( __FILE__ );
}

$path = array( $IP, "$IP/includes", "$IP/languages" );
set_include_path( implode( PATH_SEPARATOR, $path ) . PATH_SEPARATOR . get_include_path() );

require_once( "$IP/includes/DefaultSettings.php" );

# If PHP's memory limit is very low, some operations may fail.
# ini_set( 'memory_limit', '20M' );

if ( $wgCommandLineMode ) {
   if ( isset( $_SERVER ) && array_key_exists( 'REQUEST_METHOD', $_SERVER ) ) {
      die( "This script must be run from the command line\n" );
   }
}
## Uncomment this to disable output compression
# $wgDisableOutputCompression = true;

$wgSitename         = "OnePieceWiki";

## The URL base path to the directory containing the wiki;
## defaults for all runtime URL paths are based off of this.
## For more information on customizing the URLs please see:
## http://www.mediawiki.org/wiki/Manual:Short_URL
$wgScriptPath       = "/mkportal/modules/mediawiki";
$wgScriptExtension  = ".php";

## UPO means: this is also a user preference option

$wgEnableEmail      = false;
$wgEnableUserEmail  = false; # UPO

$wgEmergencyContact = "morths@gmail.com";
$wgPasswordSender = "morths@gmail.com";

$wgEnotifUserTalk = false; # UPO
$wgEnotifWatchlist = false; # UPO
$wgEmailAuthentication = false;

## Database settings
$wgDBtype           = "mysql";
$wgDBserver         = "localhost";
$wgDBname           = "PHPBB3";
$wgDBuser           = "*****";
$wgDBpassword       = "*****";

# MySQL specific settings
$wgDBprefix         = "opmw_";

# MySQL table options to use during installation or update
$wgDBTableOptions   = "ENGINE=InnoDB, DEFAULT CHARSET=utf8";

# Experimental charset support for MySQL 4.1/5.0.
$wgDBmysql5 = true;

## Shared memory settings
$wgMainCacheType = CACHE_NONE;
$wgMemCachedServers = array();

## To enable image uploads, make sure the 'images' directory
## is writable, then set this to true:
$wgEnableUploads       = false;
# $wgUseImageMagick = true;
# $wgImageMagickConvertCommand = "/usr/bin/convert";

## If you use ImageMagick (or any other shell command) on a
## Linux server, this will need to be set to the name of an
## available UTF-8 locale
# $wgShellLocale = "en_US.UTF-8";

## If you want to use image uploads under safe mode,
## create the directories images/archive, images/thumb and
## images/temp, and make them all writable. Then uncomment
## this, if it's not already uncommented:
# $wgHashedUploadDirectory = false;

## If you have the appropriate support software installed
## you can enable inline LaTeX equations:
$wgUseTeX           = false;

$wgLocalInterwiki   = $wgSitename;

$wgLanguageCode = "el";

$wgProxyKey = "47929ee91931015d2c4fd8b14d5588a335ebdead3fab0fde655caeb8684c23b6";

## Default skin: you can change the default skin. Use the internal symbolic
## names, ie 'standard', 'nostalgia', 'cologneblue', 'monobook':
$wgDefaultSkin = 'monobook';

## For attaching licensing metadata to pages, and displaying an
## appropriate copyright notice / icon. GNU Free Documentation
## License and Creative Commons licenses are supported so far.
# $wgEnableCreativeCommonsRdf = true;
$wgRightsPage = ""; # Set to the title of a wiki page that describes your license/copyright
$wgRightsUrl = "";
$wgRightsText = "";
$wgRightsIcon = "";
# $wgRightsCode = ""; # Not yet used

$wgDiff3 = "";


# When you make changes to this configuration file, this will make
# sure that cached pages are cleared.
$wgCacheEpoch = max( $wgCacheEpoch, gmdate( 'YmdHis', @filemtime( __FILE__ ) ) );

// PHPBB User Database Plugin. (Requires MySQL Database)
require_once './extensions/Auth_phpBB.php';

$wgAuth_Config = array(); // Clean.

$wgAuth_Config['WikiGroupName'] = 'Wiki';       // Name of your PHPBB group
                                                // users need to be a member
                                                // of to use the wiki. (i.e. wiki)
                  // This can also be set to an array
                  // of group names to use more then
                  // one. (ie.
                  // $wgAuth_Config['WikiGroupName'][] = 'Wiki';
                  // $wgAuth_Config['WikiGroupName'][] = 'Wiki2';
                  // or
                  // $wgAuth_Config['WikiGroupName'] = array('Wiki', 'Wiki2');
                  // )


$wgAuth_Config['UseWikiGroup'] = true;          // This tells the Plugin to require
                                                // a user to be a member of the above
                                                // phpBB group. (ie. wiki) Setting
                                                // this to false will let any phpBB
                                                // user edit the wiki.

$wgAuth_Config['UseExtDatabase'] = false;       // This tells the plugin that the phpBB tables
                                                // are in a different database then the wiki.
                                                // The default settings is false.

//$wgAuth_Config['MySQL_Host']        = 'localhost';      // phpBB MySQL Host Name.
//$wgAuth_Config['MySQL_Username']    = '******';       // phpBB MySQL Username.
//$wgAuth_Config['MySQL_Password']    = '******';       // phpBB MySQL Password.
//$wgAuth_Config['MySQL_Database']    = 'PHPBB3';       // phpBB MySQL Database Name.

$wgAuth_Config['UserTB']         = 'phpbb_users';       // Name of your PHPBB user table. (i.e. phpbb_users)
$wgAuth_Config['GroupsTB']       = 'phpbb_groups';      // Name of your PHPBB groups table. (i.e. phpbb_groups)
$wgAuth_Config['User_GroupTB']   = 'phpbb_user_group';  // Name of your PHPBB user_group table. (i.e. phpbb_user_group)
$wgAuth_Config['PathToPHPBB']    = '/phpBB3/';         // Path from this file to your phpBB install.

// Local
$wgAuth_Config['LoginMessage']   = '<b>You need a phpBB account to login.</b><br /><a href="' . $wgAuth_Config['PathToPHPBB'] .
                                   'ucp.php?mode=register">Click here to create an account.</a>'; // Localize this message.
$wgAuth_Config['NoWikiError']    = 'You are not a member of the required phpBB group.'; // Localize this message.

$wgAuth = new Auth_phpBB($wgAuth_Config);     // Auth_phpBB Plugin.


Any help appreciated!!

Thnx in advance.
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Tue Dec 16, 2008 10:45 am    Post subject: Reply with quote
Take a look at this post.

http://uber.leetphp.com/forums/viewtopic.php?t=137

And see if it helps you trouble shoot your error.
Back to top
View user's profile Send private message
morths



Joined: 15 Dec 2008
Posts: 3

PostPosted: Tue Dec 16, 2008 11:21 am    Post subject: Reply with quote
Already did man.

Doesn't help...

Before take the decision to register and post i checked ALL relative posts in this forum but i can't fix the problem...

plz help...
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Tue Dec 16, 2008 11:16 pm    Post subject: Reply with quote
try changing this.

Code:
$wgAuth_Config['PathToPHPBB']    = '/phpBB3/';


to

Code:
$wgAuth_Config['PathToPHPBB']    = 'phpBB3/';
Back to top
View user's profile Send private message
morths



Joined: 15 Dec 2008
Posts: 3

PostPosted: Wed Dec 17, 2008 4:02 am    Post subject: Reply with quote
ok man!

i fixed it! problem was i hadn't put mediawiki in the EXACTLY SAME DIRECTORY as phpbb3.

Yesterday i uploaded mediawiki in the exact same directory as phpbb3 to test if this was the problem, then i tried log in with my phpbb3 username & pass and... finally no more problems!!!

thnx anyway!
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Wed Dec 17, 2008 11:22 am    Post subject: Reply with quote
ok. Good luck with that.
Back to top
View user's profile Send private message
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // How do I? All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

alexisBlue v1.2 // Theme Created By: Andrew Charron and Web Hosting Bluebook
Powered by phpBB © 2001, 2002 phpBB Group