Mediawiki 1.15.1 and PHPBB 3.0.6 -

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // General
View previous topic :: View next topic  
Author Message
MrShlee



Joined: 24 Nov 2009
Posts: 2

PostPosted: Tue Nov 24, 2009 10:36 am    Post subject: Mediawiki 1.15.1 and PHPBB 3.0.6 - Reply with quote
Using this combo, I tried and failed. Should this work?

The 'root' admin seems to be active, but this project hasn't had a public release in awhile and Id love to know if this project is still active in one way or another.. as it seems this is the be all and end all of Mediawiki integration.

Id love to get this working, any ideas/hints?
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Tue Nov 24, 2009 5:37 pm    Post subject: Reply with quote
Yes, I am still active. From what I have seem people post the plug-in should work with MW 1.15.1
Back to top
View user's profile Send private message
MrShlee



Joined: 24 Nov 2009
Posts: 2

PostPosted: Wed Nov 25, 2009 4:11 am    Post subject: Reply with quote
root wrote:
Yes, I am still active. From what I have seem people post the plug-in should work with MW 1.15.1


It might be a PHPBB 3.0.6 related issue, but instead of complaining, I'll actually start looking into it and getting you some feed back.

Is another release due? Id love to see something with the patches people have posted in this forum recently.
Back to top
View user's profile Send private message
love_bug



Joined: 26 Nov 2009
Posts: 3

PostPosted: Thu Nov 26, 2009 10:57 am    Post subject: Reply with quote
Hello sir,
This extension is really nice, I tried to find similar extension but i've failed. It was working nice with my old board 3.0, but since i've upgraded my board to 3.0.6.. it's nolonger working. I can login to wiki, but i get following error:
You do not have permission to edit this page, for the following reason:
The action you have requested is limited to users in the group: Users.


Following are my settings :
Code:
// PHPBB User Database Plugin. (Requires MySQL Database)
require_once './extensions/Auth_phpBB.php';

$wgAuth_Config = array(); // Clean.

$wgAuth_Config['WikiGroupName'] = 'Registered Users';       // Name of your PHPBB group
                                                // users need to be a member
                                                // of to use the wiki. (i.e. wiki)
                  // This can also be set to an array
                  // of group names to use more then
                  // one. (ie.
                  // $wgAuth_Config['WikiGroupName'][] = 'Wiki';
                  // $wgAuth_Config['WikiGroupName'][] = 'Wiki2';
                  // or
                  // $wgAuth_Config['WikiGroupName'] = array('Wiki', 'Wiki2');
                  // )


$wgAuth_Config['UseWikiGroup'] = false;          // This tells the Plugin to require
                                                // a user to be a member of the above
                                                // phpBB group. (ie. wiki) Setting
                                                // this to false will let any phpBB
                                                // user edit the wiki.

$wgAuth_Config['UseExtDatabase'] = false;       // This tells the plugin that the phpBB tables
                                                // are in a different database then the wiki.
                                                // The default settings is false.

//$wgAuth_Config['MySQL_Host']        = 'localhost';      // phpBB MySQL Host Name.
//$wgAuth_Config['MySQL_Username']    = 'username';       // phpBB MySQL Username.
//$wgAuth_Config['MySQL_Password']    = 'password';       // phpBB MySQL Password.
//$wgAuth_Config['MySQL_Database']    = 'database';       // phpBB MySQL Database Name.

$wgAuth_Config['UserTB']         = 'phpbb_users';       // Name of your PHPBB user table. (i.e. phpbb_users)
$wgAuth_Config['GroupsTB']       = 'phpbb_groups';      // Name of your PHPBB groups table. (i.e. phpbb_groups)
$wgAuth_Config['User_GroupTB']   = 'phpbb_user_group';  // Name of your PHPBB user_group table. (i.e. phpbb_user_group)
$wgAuth_Config['PathToPHPBB']    = '../';         // Path from this file to your phpBB install.

// Local
$wgAuth_Config['LoginMessage']   = '<b>You need Sikkimonline Account to login.</b><br /><a href="' . $wgAuth_Config['PathToPHPBB'] .
                                   'ucp.php?mode=register">Click here to create an account.</a>'; // Localize this message.
$wgAuth_Config['NoWikiError']    = 'You are not a member of the required Sikkimonline group.'; // Localize this message.

$wgAuth = new Auth_phpBB($wgAuth_Config);     // Auth_phpBB Plugin.


Thank you
Back to top
View user's profile Send private message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Tue Dec 01, 2009 1:39 pm    Post subject: Reply with quote
that error message

Quote:
You do not have permission to edit this page, for the following reason:
The action you have requested is limited to users in the group: Users.


is not from the plug-in. Sounds like a MW error.
Back to top
View user's profile Send private message
krillmeed



Joined: 25 Dec 2009
Posts: 2

PostPosted: Fri Dec 25, 2009 7:25 am    Post subject: Same versions Reply with quote
I have also newly installed both these same versions of each. Has anyone managed to get them working together Crying or Very sad Sorry about having a problem as a first introduction Wink I should add when i added the code to the local settings on the wiki, the wiki page just went blank kind of thing, but both the wiki and the new forum work perfectly independently Cool
Back to top
View user's profile Send private message Send e-mail
krillmeed



Joined: 25 Dec 2009
Posts: 2

PostPosted: Sat Dec 26, 2009 7:09 am    Post subject: Sorry Reply with quote
Could have been my fault, after rereading the instructions i uploaded the 3 files into extention folder, not the folder itself with them in. So far so good at least the wiki does not disappear Embarassed
Back to top
View user's profile Send private message Send e-mail
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Sat Dec 26, 2009 8:27 am    Post subject: Reply with quote
thanks for the feedback krillmeed
Back to top
View user's profile Send private message
Nomadic26



Joined: 22 Jan 2010
Posts: 2

PostPosted: Fri Jan 22, 2010 4:49 am    Post subject: Reply with quote
Hi, I just did an automated install of PHPBB 3.0.6, integrated x7chat easily, and am not having trouble with Mediawiki 1.15.1

I have uploaded the 3 files into the extension folder, I have added the above code to the localsetting.php . However I get this error :

Unexpected non-MediaWiki exception encountered, of type "Exception"
exception 'Exception' with message 'Unable to view external table<br />MySQL Error Number: 1146<br />MySQL Error Message: Table 'bodywor1_mdw1.phpbb3_users' doesn't exist<br /><br />' in /home1/bodywor1/public_html/ufpx/database/extensions/Auth_phpBB.php:699

How do I verify the name and location of my user tables? Or is there some step I possibly missed? Thanks.
Back to top
View user's profile Send private message
Nomadic26



Joined: 22 Jan 2010
Posts: 2

PostPosted: Fri Jan 22, 2010 6:24 am    Post subject: Reply with quote
Problem resolved, thanks to referencing this post :

http://uber.leetphp.com/forums/viewtopic.php?p=980#980

The step I was missing was copying over the correct MySQL database/username/password which is located in the PHPBB/config.php file. As well as table header of phpbb_ instead of phpbb3_ .
Back to top
View user's profile Send private message
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // General All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

alexisBlue v1.2 // Theme Created By: Andrew Charron and Web Hosting Bluebook
Powered by phpBB © 2001, 2002 phpBB Group