MediaWiki_PHPBB_Auth_v3.0 Beta

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // General
View previous topic :: View next topic  
Author Message
root
Site Admin


Joined: 24 Jun 2005
Posts: 471

PostPosted: Wed Oct 03, 2007 2:21 pm    Post subject: Reply with quote
MediaWiki_PHPBB_Auth_v3.0 Beta

I know I just posted about the requirement change but here is another post about the release of the Auth_phpBB 3.0 beta code. It's beta because phpBB3 might change before the final release. But there is also a really good chance the plug-in will still work when phpBB3 is released.

Change:

Better Object code.Better error reporting.Now reports to the user that they are not a member of the Wiki group when logging in.
MediaWiki Hook usage.
Removed most Globals.No more character conversions phpBB3 uses UTF8 by default.
Uses phpBB's UTF8 code for case folding of usernames. Must better support for non-english users.
Removed secruity hole where a user could request to join the Wiki group and login before being approved.
Requires access to copy of phpBB3. (Sorry multi server users). Note: Does not need to be functional.Requires php5Works with MediaWiki 1.11.xConverted MediaWiki's AuthPlugin into a true interface.


Back to top
View user's profile Send private message
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    php|uber.leet Forum Index // General All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

alexisBlue v1.2 // Theme Created By: Andrew Charron and Web Hosting Bluebook
Powered by phpBB © 2001, 2002 phpBB Group